Skip to content

Commit

Permalink
py-pip_audit: update to 2.5.1.
Browse files Browse the repository at this point in the history
## [2.5.1]

### Fixed

* Fixed a crash on Windows caused by multiple open file handles to
  input requirements ([#551](pypa/pip-audit#551))

## [2.5.0]

### Changed

* Improved error messaging when a requirements input or indirect dependency
  has an invalid (non-PEP 440) requirements specifier
  ([#507](pypa/pip-audit#507))

* `pip-audit`'s handling of dependency resolution has been significantly
  refactored and simplified ([#523](pypa/pip-audit#523))

### Fixed

* Fixed a potential crash on invalid unicode in subprocess streams
  ([#536](pypa/pip-audit#536))

## [2.4.15]

**YANKED**

### Fixed

* Fixed an issue where hash checking would fail when using third-party indices
  ([#462](pypa/pip-audit#462))

* Fixed the behavior of the `--skip-editable` flag, which had regressed
  with an internal API change
  ([#499](pypa/pip-audit#499))

* Fixed a dependency resolution bug that can potentially be triggered when
  multiple packages have the same subdependency
  ([#488](pypa/pip-audit#488))
  • Loading branch information
0-wiz-0 committed Mar 19, 2023
1 parent 6cfedfd commit 461ae18
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 17 deletions.
9 changes: 3 additions & 6 deletions security/py-pip-audit/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.22 2023/03/16 08:48:02 adam Exp $
# $NetBSD: Makefile,v 1.23 2023/03/19 07:18:43 wiz Exp $

DISTNAME= pip_audit-2.4.14
DISTNAME= pip_audit-2.5.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= security python
# pypi file does not include tests
Expand All @@ -15,18 +15,17 @@ COMMENT= Scan Python environments for known vulnerabilities
LICENSE= apache-2.0

TOOL_DEPENDS+= ${PYPKGPREFIX}-flit_core-[0-9]*:../../devel/py-flit_core
# unlisted but used
DEPENDS+= ${PYPKGPREFIX}-cachecontrol>=0.12.10:../../devel/py-cachecontrol
DEPENDS+= ${PYPKGPREFIX}-cyclonedx-python-lib>=2.0.0:../../security/py-cyclonedx-python-lib
DEPENDS+= ${PYPKGPREFIX}-html5lib>=1.1:../../textproc/py-html5lib
DEPENDS+= ${PYPKGPREFIX}-packaging>=23.0.0:../../devel/py-packaging
DEPENDS+= ${PYPKGPREFIX}-pip-api>=0.0.28:../../devel/py-pip-api
DEPENDS+= ${PYPKGPREFIX}-pip-requirements-parser>=32.0.0:../../devel/py-pip-requirements-parser
DEPENDS+= ${PYPKGPREFIX}-resolvelib>=0.8.0:../../devel/py-resolvelib
DEPENDS+= ${PYPKGPREFIX}-rich>=12.4:../../comms/py-rich
DEPENDS+= ${PYPKGPREFIX}-toml>=0.10:../../textproc/py-toml
TEST_DEPENDS+= ${PYPKGPREFIX}-pretend-[0-9]*:../../devel/py-pretend
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test
TEST_DEPENDS+= git-base-[0-9]*:../../devel/git-base

PYTHON_VERSIONS_INCOMPATIBLE= 27

Expand All @@ -36,8 +35,6 @@ post-install:
cd ${DESTDIR}${PREFIX}/bin && \
${MV} pip-audit pip-audit-${PYVERSSUFFIX} || ${TRUE}

# as of 2.4.3
# 1 failed, 168 passed
TEST_ENV+= PYTHONPATH=${WRKSRC}/build/lib:${WRKSRC}/build/lib/test
do-test:
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX}
Expand Down
8 changes: 1 addition & 7 deletions security/py-pip-audit/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.7 2022/07/14 13:21:26 wiz Exp $
@comment $NetBSD: PLIST,v 1.8 2023/03/19 07:18:43 wiz Exp $
bin/pip-audit-${PYVERSSUFFIX}
${PYSITELIB}/${WHEEL_INFODIR}/INSTALLER
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
Expand Down Expand Up @@ -28,12 +28,6 @@ ${PYSITELIB}/pip_audit/_dependency_source/pyproject.py
${PYSITELIB}/pip_audit/_dependency_source/pyproject.pyc
${PYSITELIB}/pip_audit/_dependency_source/requirement.py
${PYSITELIB}/pip_audit/_dependency_source/requirement.pyc
${PYSITELIB}/pip_audit/_dependency_source/resolvelib/__init__.py
${PYSITELIB}/pip_audit/_dependency_source/resolvelib/__init__.pyc
${PYSITELIB}/pip_audit/_dependency_source/resolvelib/pypi_provider.py
${PYSITELIB}/pip_audit/_dependency_source/resolvelib/pypi_provider.pyc
${PYSITELIB}/pip_audit/_dependency_source/resolvelib/resolvelib.py
${PYSITELIB}/pip_audit/_dependency_source/resolvelib/resolvelib.pyc
${PYSITELIB}/pip_audit/_fix.py
${PYSITELIB}/pip_audit/_fix.pyc
${PYSITELIB}/pip_audit/_format/__init__.py
Expand Down
8 changes: 4 additions & 4 deletions security/py-pip-audit/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.19 2023/03/16 08:48:02 adam Exp $
$NetBSD: distinfo,v 1.20 2023/03/19 07:18:43 wiz Exp $

BLAKE2s (pip_audit-2.4.14.tar.gz) = a7bf015e61521f34ecaa49d5f00c2d86d79be58d428c02dd83cc3f0afdf4a2f4
SHA512 (pip_audit-2.4.14.tar.gz) = c4c21b3b1863c10a7917ab957c646022901e70b5d580c22217cd2b32269380a75ef671cdafea4a941f35e88004a2cd04082defba1d713decb26968ad941cd818
Size (pip_audit-2.4.14.tar.gz) = 75131 bytes
BLAKE2s (pip_audit-2.5.1.tar.gz) = 7ef7dffa97bba633582feeff4383570cefccad0444afb8bc1dedfa3fb32bdaa6
SHA512 (pip_audit-2.5.1.tar.gz) = 429475348cf92cad0c0c64dfd5f92c679fe6c79900f6ba369a4558c29fd5a1a7c469197770a47d34c2248d3225fbc8a538464a654bef92013fe035a754c718dd
Size (pip_audit-2.5.1.tar.gz) = 66384 bytes

0 comments on commit 461ae18

Please sign in to comment.