forked from freebsd/freebsd-ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
graphics/pdfpc: update webkti2gtk3 API version 4.1
Pull Request: freebsd#266
- Loading branch information
1 parent
420dc67
commit 49af49a
Showing
2 changed files
with
35 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,7 +2,7 @@ PORTNAME= pdfpc | |
DISTVERSION= 4.6.0 | ||
CATEGORIES= graphics | ||
DISTVERSIONPREFIX= v | ||
PORTREVISION= 6 | ||
PORTREVISION= 7 | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Keynote-like multi-monitor presentation viewer | ||
|
@@ -18,8 +18,8 @@ LIB_DEPENDS= libgee-0.8.so:devel/libgee \ | |
libmarkdown.so:textproc/discount \ | ||
libpoppler-glib.so:graphics/poppler-glib \ | ||
libqrencode.so:graphics/libqrencode \ | ||
libsoup-2.4.so:devel/libsoup \ | ||
libwebkit2gtk-4.0.so:www/webkit2-gtk3 | ||
libsoup-3.0.so:devel/libsoup3 \ | ||
libwebkit2gtk-4.1.so:www/webkit2-gtk3 | ||
|
||
USES= cmake compiler:c11 gnome gstreamer pkgconfig vala:build xorg | ||
USE_GNOME= cairo gdkpixbuf2 gtk30 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
--- src/CMakeLists.txt.orig 2024-05-24 19:59:23 UTC | ||
+++ src/CMakeLists.txt | ||
@@ -30,16 +30,16 @@ if (MDVIEW) | ||
endif () | ||
|
||
if (MDVIEW) | ||
- pkg_check_modules(WEBKIT REQUIRED webkit2gtk-4.0) | ||
- set(MDVIEW_PACKAGES webkit2gtk-4.0) | ||
+ pkg_check_modules(WEBKIT REQUIRED webkit2gtk-4.1) | ||
+ set(MDVIEW_PACKAGES webkit2gtk-4.1) | ||
set(EXTRA_VALA_OPTIONS ${EXTRA_VALA_OPTIONS} -D MDVIEW) | ||
endif () | ||
|
||
if (REST) | ||
- pkg_check_modules(SOUP REQUIRED libsoup-2.4) | ||
+ pkg_check_modules(SOUP REQUIRED libsoup-3.0) | ||
pkg_check_modules(QRENCODE REQUIRED libqrencode) | ||
set(REST_PACKAGES | ||
- libsoup-2.4 | ||
+ libsoup-3.0 | ||
) | ||
|
||
if (${CMAKE_HOST_WIN32}) | ||
@@ -136,7 +136,7 @@ PACKAGES | ||
vala_precompile(VALA_C | ||
${VALA_SRC} | ||
PACKAGES | ||
- webkit2gtk-4.0 | ||
+ webkit2gtk-4.1 | ||
json-glib-1.0 | ||
gio-2.0 | ||
gee-0.8 |