forked from freebsd/freebsd-ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
www/midori: update webkit2gtk3 API version to 4.1
Pull Request: freebsd#266
- Loading branch information
1 parent
91c81ae
commit 7b2c9cf
Showing
2 changed files
with
34 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
PORTNAME= midori | ||
PORTVERSION= 9.0 | ||
DISTVERSIONPREFIX= v | ||
PORTREVISION= 10 | ||
PORTREVISION= 11 | ||
CATEGORIES= www | ||
|
||
MAINTAINER= [email protected] | ||
|
@@ -12,11 +12,11 @@ LICENSE= LGPL21 MIT | |
LICENSE_COMB= multi | ||
|
||
LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \ | ||
libsoup-2.4.so:devel/libsoup \ | ||
libsoup-3.0.so:devel/libsoup3 \ | ||
libp11-kit.so:security/p11-kit \ | ||
libgcr-base-3.so:security/gcr \ | ||
libpeas-1.0.so:devel/libpeas \ | ||
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \ | ||
libwebkit2gtk-4.1.so:www/webkit2-gtk3 \ | ||
libharfbuzz.so:print/harfbuzz | ||
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
--- CMakeLists.txt.orig 2024-05-24 20:53:33 UTC | ||
+++ CMakeLists.txt | ||
@@ -46,24 +46,24 @@ pkg_check_modules(DEPS REQUIRED | ||
pkg_check_modules(DEPS REQUIRED | ||
sqlite3>=3.6.19 | ||
gio-2.0>=2.46.2 | ||
- libsoup-2.4>=2.48.0 | ||
+ libsoup-3.0>=2.48.0 | ||
) | ||
-set(PKGS sqlite3 gio-2.0 libsoup-2.4) | ||
+set(PKGS sqlite3 gio-2.0 libsoup-3.0) | ||
|
||
pkg_check_modules(DEPS_GTK REQUIRED | ||
gtk+-3.0>=3.12.0 | ||
- webkit2gtk-4.0>=2.16.6 | ||
+ webkit2gtk-4.1>=2.16.6 | ||
gcr-ui-3>=2.32 | ||
libpeas-gtk-1.0 | ||
json-glib-1.0>=0.12 | ||
libarchive | ||
) | ||
-set(PKGS ${PKGS} gtk+-3.0 libsoup-2.4 gcr-ui-3 libpeas-gtk-1.0 json-glib-1.0 posix) | ||
+set(PKGS ${PKGS} gtk+-3.0 libsoup-3.0 gcr-ui-3 libpeas-gtk-1.0 json-glib-1.0 posix) | ||
set(EXTRA_VAPIS | ||
${CMAKE_SOURCE_DIR}/vapi/config.vapi | ||
${CMAKE_SOURCE_DIR}/vapi/libarchive.vapi | ||
${CMAKE_SOURCE_DIR}/vapi/webkit2gtk-4.0.vapi | ||
${CMAKE_SOURCE_DIR}/vapi/javascriptcoregtk-4.0.vapi) | ||
|
||
add_definitions("-DGCR_API_SUBJECT_TO_CHANGE") | ||
set(CFLAGS "${CFLAGS} -g") |