forked from msys2/MINGW-packages
-
Notifications
You must be signed in to change notification settings - Fork 45
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge remote-tracking branch 'upstream/master'
- Loading branch information
Showing
10 changed files
with
851 additions
and
103 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- gnutls-3.4.0/lib/includes/gnutls/gnutls.h.in.orig 2015-04-09 23:38:42.018400000 +0300 | ||
+++ gnutls-3.4.0/lib/includes/gnutls/gnutls.h.in 2015-04-09 23:39:31.860400000 +0300 | ||
@@ -67,6 +67,8 @@ | ||
#define GNUTLS_CIPHER_RIJNDAEL_CBC GNUTLS_CIPHER_AES_128_CBC | ||
#define GNUTLS_CIPHER_ARCFOUR GNUTLS_CIPHER_ARCFOUR_128 | ||
|
||
+#define GNUTLS_INTERNAL_BUILD 1 | ||
+ | ||
#if !defined(GNUTLS_INTERNAL_BUILD) && defined(_WIN32) | ||
# define _SYM_EXPORT __declspec(dllimport) | ||
#else |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
From 7e63027a5caafa55dcca65c5b9bff3bf76c5a41c Mon Sep 17 00:00:00 2001 | ||
From: Nikos Mavrogiannopoulos <[email protected]> | ||
Date: Thu, 9 Apr 2015 16:00:43 +0200 | ||
Subject: [PATCH] remove duplicate entries from manpages Makefile | ||
|
||
--- | ||
doc/manpages/Makefile.am | 5 +---- | ||
1 file changed, 1 insertion(+), 4 deletions(-) | ||
|
||
diff --git a/doc/manpages/Makefile.am b/doc/manpages/Makefile.am | ||
index 8e793d3..68de757 100644 | ||
--- a/doc/manpages/Makefile.am | ||
+++ b/doc/manpages/Makefile.am | ||
@@ -134,11 +134,8 @@ APIMANS += gnutls_certificate_get_peers.3 | ||
APIMANS += gnutls_certificate_get_peers_subkey_id.3 | ||
APIMANS += gnutls_certificate_get_trust_list.3 | ||
APIMANS += gnutls_certificate_get_verify_flags.3 | ||
-APIMANS += gnutls_certificate_get_verify_flags.3 | ||
-APIMANS += gnutls_certificate_get_x509_crt.3 | ||
APIMANS += gnutls_certificate_get_x509_crt.3 | ||
APIMANS += gnutls_certificate_get_x509_key.3 | ||
-APIMANS += gnutls_certificate_get_x509_key.3 | ||
APIMANS += gnutls_certificate_send_x509_rdn_sequence.3 | ||
APIMANS += gnutls_certificate_server_set_request.3 | ||
APIMANS += gnutls_certificate_set_dh_params.3 | ||
@@ -1101,7 +1098,7 @@ compare-makefile: | ||
@echo "******************************************************************************" | ||
@echo "If the following step fails copy $(srcdir)/doc/manpages/tmp-compare-makefile to doc/manpages/Makefile.am" | ||
@echo "******************************************************************************" | ||
- FUNCS=`cat $(top_srcdir)/lib/includes/gnutls/*.h | $(top_srcdir)/doc/scripts/getfuncs.pl|sort -d`; \ | ||
+ FUNCS=`cat $(top_srcdir)/lib/includes/gnutls/*.h | $(top_srcdir)/doc/scripts/getfuncs.pl|sort -d|uniq`; \ | ||
MANS=""; \ | ||
for i in $$FUNCS; do \ | ||
MANS="$$MANS\nAPIMANS += $$i.3"; \ | ||
-- | ||
libgit2 0.21.4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Maintainer: Renato Silva <[email protected]> | ||
|
||
_realname='libmongoose' | ||
url='https://github.com/cesanta/mongoose' | ||
pkgdesc=' Embedded web server for C/C++ (mingw-w64)' | ||
license=('GPL2') | ||
arch=('any') | ||
pkgver=r1764.eef70aa | ||
pkgrel=1 | ||
|
||
pkgname=(${MINGW_PACKAGE_PREFIX}-${_realname}-git) | ||
provides=(${MINGW_PACKAGE_PREFIX}-${_realname}) | ||
conflicts=(${MINGW_PACKAGE_PREFIX}-${_realname}) | ||
makedepends=(${MINGW_PACKAGE_PREFIX}-gcc) | ||
source=(${_realname}::'git+https://github.com/cesanta/mongoose') | ||
sha1sums=('SKIP') | ||
|
||
pkgver() { | ||
cd "${srcdir}/${_realname}" | ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" | ||
} | ||
|
||
build() { | ||
cd "${srcdir}/${_realname}" | ||
# See https://github.com/cesanta/mongoose/issues/326 | ||
# See https://github.com/cesanta/mongoose/issues/506 | ||
gcc -c -DFD_SETSIZE=1024 mongoose.c -o mongoose.o | ||
ar rcs libmongoose.a mongoose.o | ||
gcc -shared -o libmongoose.dll mongoose.o -Wl,--out-implib,libmongoose.dll.a -lws2_32 | ||
} | ||
|
||
package() { | ||
cd "${srcdir}/${_realname}" | ||
install -D -m644 mongoose.h "${pkgdir}${MINGW_PREFIX}/include/mongoose.h" | ||
install -D -m644 libmongoose.a "${pkgdir}${MINGW_PREFIX}/lib/libmongoose.a" | ||
install -D -m644 libmongoose.dll.a "${pkgdir}${MINGW_PREFIX}/lib/libmongoose.dll.a" | ||
install -D -m755 libmongoose.dll "${pkgdir}${MINGW_PREFIX}/bin/libmongoose.dll" | ||
install -D -m644 LICENSE "${pkgdir}${MINGW_PREFIX}/share/licenses/${_realname}/LICENSE" | ||
} |
Oops, something went wrong.