Skip to content

Commit

Permalink
olsrd: update to latest 2023-06-13
Browse files Browse the repository at this point in the history
Fixes compilation with GCC14.

Signed-off-by: Rosen Penev <[email protected]>
  • Loading branch information
neheb committed Jun 9, 2024
1 parent 4ac486b commit a3950ba
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 3 deletions.
6 changes: 3 additions & 3 deletions olsrd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,13 +6,13 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=olsrd
PKG_SOURCE_DATE:=2023-06-12
PKG_SOURCE_DATE:=2023-06-13
PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/OLSR/olsrd.git
PKG_SOURCE_VERSION:=a9b3f1ac6e73a39b5bd97d1e66b1e039998314f5
PKG_MIRROR_HASH:=2bd60af2a79711d7db2a9e42b48f757ab48712cfdeb0115d5384718010818e19
PKG_SOURCE_VERSION:=204a44adc7e98b826833b6fac2f7673735832427
PKG_MIRROR_HASH:=6d8d3656ccad83799c23b62c3dbcfd6c8251e50e6705adb655492a64128a43ef

PKG_MAINTAINER:=Nick Hainke <[email protected]>
PKG_BUILD_PARALLEL:=0
Expand Down
46 changes: 46 additions & 0 deletions olsrd/patches/010-gcc14.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
--- a/lib/filtergw/src/olsrd_filtergw.c
+++ b/lib/filtergw/src/olsrd_filtergw.c
@@ -77,7 +77,7 @@ struct originator_list {

struct filter_group {
struct originator_list *originator_list;
- struct hna_group *next;
+ struct filter_group *next;
};

static struct filter_group *filter_groups = NULL;
@@ -128,7 +128,7 @@ static int set_plugin_filter(const char
olsr_exit("FILTERGW: Out of memory", EXIT_FAILURE);
}
filter_groups = new;
- new->next = (struct hna_group *)filter_groups;
+ new->next = filter_groups;
}

filter_groups->originator_list =
--- a/src/linux/kernel_routes_nl.c
+++ b/src/linux/kernel_routes_nl.c
@@ -156,15 +156,14 @@ static void rtnetlink_read(int sock, voi
int len, plen;
struct iovec iov;
struct sockaddr_nl nladdr;
- struct msghdr msg = {
- &nladdr,
- sizeof(nladdr),
- &iov,
- 1,
- NULL,
- 0,
- 0
- };
+ struct msghdr msg;
+ msg.msg_name = &nladdr;
+ msg.msg_namelen = sizeof(nladdr);
+ msg.msg_iov = &iov;
+ msg.msg_iovlen = 1;
+ msg.msg_control = NULL;
+ msg.msg_controllen = 0;
+ msg.msg_flags = 0;

char buffer[4096];
struct nlmsghdr *nlh = (struct nlmsghdr *)ARM_NOWARN_ALIGN(buffer);

0 comments on commit a3950ba

Please sign in to comment.